Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Whirlpool Range Bake Element Not Heating  (Read 4709 times)

Offline TechnicianBrian

  • Technician
  • Member Since: Dec 2007
  • Posts: 390
  • Country: us
    • TechnicianBrian.com
Whirlpool Range Bake Element Not Heating
« on: April 08, 2008, 07:08:16 AM »

Model # RJE333PP0, the surface elements and broil element worked fine, but the bake element would not heat. There was no apparent damage to the element so I did a continuity check only to find it measured within specifications (11 ohms). Removed the rear of the control panel and did some voltage checks and found the L1 voltage was entering the selector switch, but did not exit the switch and enter the thermostat. Unplugged the unit and did a continuity check of the selector switch and sure enough, it was open on the bake mode, and worked fine on the broil. Replaced it with a new selector switch and now the element heats fine.



Whirlpool Range Selector Switch Part # 3150430
« Last Edit: April 08, 2008, 07:09:17 AM by AJ »