Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Ge compressor anomoly  (Read 221 times)

Offline B clark

  • VIP Member
  • Member Since: Jul 2022
  • Posts: 3
Ge compressor anomoly
« on: July 28, 2022, 08:48:15 AM »

 GFE28HMHFES
Compressor question.

 Refrigerator was purchased in 2016.
 About 2 weeks ago we noticed the fresh food compartment was getting warm and the freezer compartment was getting warm. We removed all the food and took all the plastic partitions out to get to the fresh fruit evaporator and the freezer evaporator. We noticed the fresh food evaporator had  no frost on it. The freezer  evaporator  had just a little bit of frost on it. Only frost at the very top like on the 1st winding of tubing. All fans are working fine. The only thing that is suspicious is the compressor. When I 1st pulled out the refrigerator to work on the compressor was extremely hot. You could not touch it or you burn your finger. I perform the ohm's check on the compressor all that worked out OK. I replaced starter relay cap all works fine. When the compressor is running it's completely cold on the high pressure side and it's completely cold on the low pressure side. I even evacuated the system and put in a service port on the high and low side of the compressor. Just pumping air it can pump up to 50PSI and then you can let the air out and it will pump it backup to 50 psi.  When fully charged with R134A the low side reads 0PSI and the high side reads a 100 PSI. If I turn the condenser fan off while the compressor's running the high side will start to get hot. But yet absolutely no r134a  whatsoever is reaching either evaporator. I replace the filter dryer and remove the 3 wave valve. While  I had the system open  I ran air through the high side up into the evaporators and back through the liquid capillary line. I verified there was no sealed system restriction to the evaporators because air was pouring out both capillary tubes.
 My question is is there any reliable way to test a compressor  short of just replacing it.  Is it possible to have a compressor that the windings check out resistance vals OK, and the compressor starts and runs but basically there's some kind of internal mechanical fault with the compressor and it's not generating enough pressure to drive the R134A through the capillary lines to the evaporator.
Any thoughts on this matter greatly appreciated.