Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Whirlpool LSR7233EQ0 not filling but agitating on rinse  (Read 148 times)

Offline bsn321

  • VIP Member
  • Member Since: May 2022
  • Posts: 2
Whirlpool LSR7233EQ0 not filling but agitating on rinse
« on: May 02, 2022, 02:22:00 PM »

Hi folks -

We have a LSR7233EQ0 that recently has trouble filling on rinse, but still starts agitating at some point during the rinse cycle.  Thinking fill valves which seems like easy replace, but just realizing/wondering why it's still agitating even when no water in there??  might this also/instead have something to do with fill-level pressure switch?

Any insight greatly appreciated!

Best -
Brad in MA

Offline Caddy4343

  • Technician
  • Member Since: Oct 2007
  • Posts: 263
Re: Whirlpool LSR7233EQ0 not filling but agitating on rinse
« Reply #1 on: May 02, 2022, 07:29:23 PM »
It could either be the pressure switch or a clogged air hose.  Try disconnecting the hose at the switch and blow through it.  If it's clogged it will be very hard to blow through. 


It could also be a timer/control board issue.

Offline bsn321

  • VIP Member
  • Member Since: May 2022
  • Posts: 2
Re: Whirlpool LSR7233EQ0 not filling but agitating on rinse
« Reply #2 on: May 03, 2022, 01:44:23 PM »
Thanks so much.  Yes I will check the pressure switch and the hose.  I'm assuming that if I can activate the switch by blowing into the hose, all is well.  But I will also check the hose for integrity blowing underwater, etc.

In the meantime, how can I tell if the timer/control board is operating properly?

by way of diagnosis:  I can also report that sometimes when the tub is not filling, if I turn the timer knob in/off, then on again, it starts working.  So maybe you're onto something there...

Thanks!