Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Zanussi ZDF26011WA only heating slightly  (Read 681 times)

Offline kcr

  • VIP Member
  • Member Since: Apr 2021
  • Posts: 1
Zanussi ZDF26011WA only heating slightly
« on: April 12, 2021, 07:14:15 PM »

My five year old Zanussi ZDF26011WA dishwasher is not heating correctly. On the Auto cycle, the water heats to around 38 degrees near the start of the cycle, but never reaches full temperature, and finishes cold (normally finishes hot and steaming when opened).
I have checked the following:
- Temp sensor appeared to return the correct resistance readings. I tried replacing it anyway, which made no difference
- Heater measures 24 ohms, which seems to be about right for the 2kW rating
- I can measure 12 V on the control board heater relay in the early part of the cycle, and 240V going to the heater, so the heating circuit appears to be OK, but it only seems to heat for a short period at the start of the cycle
- Pump appears to be working fine and water is spraying
- I have cleaned everything out and checked the channel to the pressure switch is clear
So the components (as far as I can check) seem to be OK, it just isn't heating for very long. Can anyone suggest what might be wrong, or anything else I can investigate?
Thanks