Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Top cook element heater strange behaviour  (Read 573 times)

Offline spricer

  • VIP Member
  • Member Since: Feb 2021
  • Posts: 2
Top cook element heater strange behaviour
« on: February 08, 2021, 09:32:03 PM »

Out of five top element heaters two are not working properly.
Left front heater does not heat at the moment. At some point I was able to turn it on but it was shutting off randomly. Also had case if I start left rear small heater left front starts working as well  :tickedoff: !?
Right front now started acting also on its own. It shuts off completely  after 5 min of heating so it is not possible to cook reliable anything on it.
I was thinking that maybe Range Relay Control Board Assembly could be the culprit but also main PCB due to the fact that two of heaters started with one button at some point.
I tested resistances on all heaters and according to service book found in the back all of them are within specs ( actually all are ~4Ω less then specs)
Would like to hear opinions.

Range is LG LRE6387ST
Thanks.

Offline spricer

  • VIP Member
  • Member Since: Feb 2021
  • Posts: 2
Re: Top cook element heater strange behaviour
« Reply #1 on: February 09, 2021, 04:50:20 PM »
I did some further tests and I am pretty sure that main board is culprit:
Tested voltage directly at switches (relays) contacts and two of them are dead (red lines) VS green one that shows voltage when switch is on.