Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Kenmore fridge 596.79323010 not defrosting automatically  (Read 166 times)

Offline shillion

  • Technician
  • Member Since: Jan 2011
  • Posts: 569
  • Country: ca
  • I have been repairing appliances since 1983
Kenmore fridge 596.79323010 not defrosting automatically
« on: October 20, 2020, 11:36:28 AM »

This fridge is very close to GX2SHBXVY05 which uses the Jazz board. But the Kenmore one uses a different board. This Kenmore 596.79323010 010 has more controls such as door alarm, water filter warning, etc. So the control board is different. In a Jazz board machine, if the diagnostic can defrost the evaporator which means the heater, defrost thermostat, the thermistors are good, I would definitely replace the Jazz board. Now this Kenmore one behaves the same, in diagnostic, defrost OK, thermistors are good, should I replace the board as well, just like the Jazz board? I never replace this board before. Please help!

Offline Dash

  • Technician
  • Member Since: Sep 2015
  • Posts: 103
Re: Kenmore fridge 596.79323010 not defrosting automatically
« Reply #1 on: October 28, 2020, 08:01:09 PM »
Holy cow, I've replaced lots of electronic control boards on Whirlpool built bottom-freezer refrigerators in the past 15 years.  Most commonly I replaced them because the defrost function wasn't working.

Offline shillion

  • Technician
  • Member Since: Jan 2011
  • Posts: 569
  • Country: ca
  • I have been repairing appliances since 1983
Re: Kenmore fridge 596.79323010 not defrosting automatically
« Reply #2 on: October 29, 2020, 03:11:02 AM »
The reason I am not sure is this board is expansive. Other cases, I only replaced the freezer evaporator thermistor even though it tested OK at the analytical process. May be I should replace the thermistor only.Did you also replace the thermistor as well?