Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Whirlpool oven no longer heats up (model YWFE745H0FS)  (Read 169 times)

Offline jjfs

  • VIP Member
  • Member Since: Apr 2020
  • Posts: 2
Whirlpool oven no longer heats up (model YWFE745H0FS)
« on: April 24, 2020, 07:41:23 PM »

I'm really struggling here. My less-than-2-year-old range (model YWFE745H0FS) no longer heats up. At first I thought it was an easy fix as I was able to remove the bottom tray to reveal the broken element. When doing so, I noticed that it had exploded in the corner.

So I ordered a similar element, replaced it and thought it was fine. It appeared to heat the oven, albeit, slower than I remembered, but at least it got to 350 now on convention. The second time baking, this time on bake mode and 30 minutes passe and it hadn't reached 300.

I removed the bottom cover once more tried to do a rapid preheat to 500 and I stopped before getting to 200 as I noticed the bottom element was not really getting hot to the touch.

Things I tried so far:
* Tested newly installed element (measured 20ohms and beeps continuity)
* Tested thermometer (measure about 1100ohms)
* Tested thermal fuse (removed wires and got continuity beep)
* Stove top get hot

I'm thinking control board or relays at this point but really don't know.

Please any suggestions at this point would be much appreciated.

Thank you.

Offline jjfs

  • VIP Member
  • Member Since: Apr 2020
  • Posts: 2
Re: Whirlpool oven no longer heats up (model YWFE745H0FS)
« Reply #1 on: April 25, 2020, 08:19:37 AM »
Just for an update: I turned on the on oven and put it to rapid preheat and opened the back and measured the volts on the on the two terminals on the bottom element and got a reading of 0 volts whereas the broiler measured 120V.

Based on this, can I deduce a faulty control board?

Offline Dash

  • Technician
  • Member Since: Sep 2015
  • Posts: 31
Re: Whirlpool oven no longer heats up (model YWFE745H0FS)
« Reply #2 on: June 09, 2020, 12:04:00 AM »
Are you getting 240V to the range?  Check the three terminals where the electric cord is attached for proper voltage.  Both the broil element and the bake element should each get 240V while heating, not 120V.