Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: GE oven - range works but oven does not  (Read 198 times)

Offline BartGojjer

  • VIP Member
  • Member Since: Nov 2019
  • Posts: 4
GE oven - range works but oven does not
« on: November 18, 2019, 03:50:11 PM »

Hello appliance enthusiasts,

yesterday we bought a GE oven at a flea market in Chicago for $180 - looked new. We brought it home and up our staircase and installed it. The range worked great and the oven turned on right away. I made some frozen Kale Puffs in the oven and it worked great. I turned the oven off. I was happy because our old oven has not been working for some time, so then I went to make another frozen treat - a samosa wrap - in the oven. I set the timer on the oven for 50 minutes and walked away. The timer went off 50 minutes later and I came back to find the samosa wrap cold. The oven would not turn on! I turned it off and on again and unplugged and plugged in the the electrical cord several times. Even this morning - the range works great - I made scrambled eggs -  but the oven will not turn on. The light turns on but I see no evidence of the fire starting beneath the oven when I turn the oven nob. Strange because this is the same problem our old oven had - the range turned on but not the oven. Can you advise me on how to troubleshoot this? Friendsgiving is this Thursday! 


thank you very much,



benG

Offline manden

  • Technician
  • Member Since: Oct 2011
  • Posts: 282
Re: GE oven - range works but oven does not
« Reply #1 on: November 18, 2019, 04:25:09 PM »
A model number may help others help you!!

Offline BartGojjer

  • VIP Member
  • Member Since: Nov 2019
  • Posts: 4
Re: GE oven - range works but oven does not
« Reply #2 on: November 18, 2019, 09:43:05 PM »
Sorry guys! GE Model # JGBS22BEH3CT

Thank you for any advice!

Offline BartGojjer

  • VIP Member
  • Member Since: Nov 2019
  • Posts: 4
Re: GE oven - range works but oven does not
« Reply #3 on: November 19, 2019, 02:37:11 PM »
Update!

Internet points to testing the oven igniter w a multimeter.

I borrowed my roommateís multimeter last night and watched a YouTube video and tried it out in the wall - set it to 200 v and put the leads in the wall socket and it read 120 v...until I turned the dial to see what happened on other settings on the multimeter. Then it started giving me strange readings. When I set it back to 200 v the multimeter now read a solid 1. I talked to my roommate this morning and he suggested that I blew the fuse on the multimeter when I turned the knob to many different settings with the leads plugged into a live wall outlet. Iím obviously new to multimeters. So I guess I need a new fuse for the multimeter now except that we Oppened the multimeter to look at the fuse and it didnít seem obviously burnt. I went ahead and ordered a new igniter off amazon for $17 (internet makes it seem like this is probably the problem) and figure I will try to get a working multimeter to test the original igniter before I actually do the repair. Maybe Iíll bring the igniter into work tomorrow to use their multimeter.
 

thank you,

Offline BartGojjer

  • VIP Member
  • Member Since: Nov 2019
  • Posts: 4
Re: GE oven - range works but oven does not
« Reply #4 on: December 05, 2019, 12:41:51 PM »
I replaced the igniter with the part I ordered from Amazon - part WB13K21 - link below to the page. This worked, as in I installed the part and turned on the gas and electricity and the oven immediately turned on. But now I have a new problem, which is the same problem our old oven had - as soon as I plug in the electricity and turn on the gas, the oven ignites - before I turn the dial to turn on the oven. When I have the dial in the off position, the oven ignites intermittently. It will turn on for a few minutes and then turn off again. Any ideas on how to solve this problem? I'm back to unplugging it and turning off the gas whenever I'm not using it to keep it safe, but it is a pain - would love to have it work properly.

Thank you,

BenG





https://www.amazon.com/gp/product/B075SHW6BY/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1