Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Whirlpool Cabrio WTW5840BW0 not finishing cycle  (Read 119 times)

Offline Blaiser

  • Technician
  • Member Since: Jun 2011
  • Posts: 700
  • Country: us
    • Buy me a beer through paypal
Whirlpool Cabrio WTW5840BW0 not finishing cycle
« on: September 24, 2019, 06:32:47 AM »

Need some insight from other techs out there. Got a call from customer saying there Whirlpool Cabrio will not start cycle. Got to house ran diagnostic and pulled 1 error code. Granted her washer definitely needs a bearing or transmission because it sounds like a Jet in high speed spin. Washer error indicated an Actuator Speed Sensor bad. Replaced the actuator and ran diagnostic to confirm. So we decided to start a load to see if Washer would start - It did - that was yesterday at 4:00 p.m. Got a call from customer and said there's something still wrong with washer it won't finish the cycle. She said it got down to 4 minutes left in cycle then went back to 52 minutes starting wash cycle all over again. It's now 5:40pm.  Any one have this issue before??? Sounds like a bad board? Your thoughts?


If so she's looking a new Board and Transmission because Gear Case is enclosed! Told her she definitely needs a new transmission at a minimum.
« Last Edit: September 24, 2019, 06:34:37 AM by Blaiser »