Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Clean light flashing 7 times  (Read 250 times)

Offline ron3033

  • VIP Member
  • Member Since: Feb 2013
  • Posts: 88
  • Country: ca
Clean light flashing 7 times
« on: April 11, 2019, 11:40:21 PM »

Hi
Kenmore Elite 665160059402

The dishwasher was pulled out to put a new sink and drain pipes under the new sink.  We put a new water fill hose and a new drain hose all routed the same as before.

We ran the first load of dishes and it seemed to end early and I went to check for any leaks, there was none but the  CLEAN light was blinking 7.  The sump had drained.  If you press cancel/drain the pump runs, but I can't get it to start when start/resume, but start resume has 3 quick red blinks .
The dishwasher was working fine before, it only got pulled out of the cabinet to get at hose replacement and sink clips.

Any suggestions as to what has happened and needs to set?

I know there is supposed to be some sort of sequence to press buttons to press for some sort of diagnostics, but do not know sequence.

Any helps appreciated as I can not afford a new DW right now.

Thanks

Offline ron3033

  • VIP Member
  • Member Since: Feb 2013
  • Posts: 88
  • Country: ca
Re: Clean light flashing 7 times
« Reply #1 on: April 12, 2019, 01:45:50 AM »
I fixed it! I took off the kick plate and felt around under the DW after I read it may be a heater element thing. I felt blindly around (power was off) and felt what I thought was a tab where one end of the element ended... but no wire??? I felt on the floor and there was a wire with a slide on connector, so I pushed it up onto the tab. I searched until I found the "heated dry > normal wash > heated dry > normal wash" code tried it and let the Dw do its' thing for about 10 to 12 minutes. When done open the door, closed it and started a wash.... it ended with a solid green clean light.

 All because the heater wire dislodged pushing DW back in place.     :)    :D   O0