Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Kenmore auto-defrost issue  (Read 185 times)

Offline Adam T

  • VIP Member
  • Member Since: Oct 2018
  • Posts: 2
Kenmore auto-defrost issue
« on: October 15, 2018, 10:10:08 PM »

I have a Kenmore Elite refrigerator model number 596.78283802. Itís a bottom freezer, double door fridge. It appears that the auto-defrost is not working. I will manually defrost it and itís good for a month or so until the frost builds so heavy that air flow is restricted and the fridge starts getting warm.

I learned how to enter manual defrost mode and when set the heater doesnít seem to get hot. I replaced the bi-metal switch already just guessing that was the issue. Taking it apart this last time, I recorded the following readings:

Defrost heater element has resistance of 31.8
Bi-metal switch has resistance of 1.7 when cold and after warmed up has infinite resistance
When I force defrost mode, the voltage sent to the heating element is 25 volts and when back into normal operating mode it still reads 19 volts?

What do you think is the issue? Do I need a new control board, or could it be something else?

Iíve kind of ruled out a Freon leak. It makes all the gurgling noises it should, and when not frosted up, seems to run just like it should.

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 4724
  • Country: us
Re: Kenmore auto-defrost issue
« Reply #1 on: October 16, 2018, 08:43:57 AM »
WPW10503278 Lots of problems with the jazz board.

Offline manden

  • VIP Member
  • Member Since: Oct 2011
  • Posts: 208
Re: Kenmore auto-defrost issue
« Reply #2 on: October 16, 2018, 09:10:23 AM »
Check the defrost circuit at the control /jazz board.

White pin 1 to Orange pin 3 should be your 31.8 ohms (heater)

White pin 1 to Brown pin 5 with defrost tstat frozen (closed) should also be about 31.8 ohms.

If both are OK I would replace the jazz board.


Offline Adam T

  • VIP Member
  • Member Since: Oct 2018
  • Posts: 2
Re: Kenmore auto-defrost issue
« Reply #3 on: October 16, 2018, 11:27:04 AM »
Okay, thanks. I will give that a try. Where might i find the jazz board - is it under temp buttons on the ceiling of the refrigerator compartment?

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 4724
  • Country: us
Re: Kenmore auto-defrost issue
« Reply #4 on: October 16, 2018, 11:54:46 AM »
Yes and there is a video if you click the part number I gave you.