Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: WFC7500VW2 Board Problems Lights Issue  (Read 116 times)

Offline Blackbeener

  • Technician
  • Member Since: Jun 2016
  • Posts: 1
  • Country: us
    • Buy me a beer through paypal
WFC7500VW2 Board Problems Lights Issue
« on: April 24, 2020, 11:09:03 AM »

Ok generally only lurk here but we are our wits end with a specific part regarding several different customer's machines. I know sometimes some of you want specifics the machine information so currently I have in the shop currently is a Maytag WFC7500VW2 / Serial# CD42810604 . I also have 3 other machines at different locations with different service technicians servicing them giving us the same problem/result when the board has been replaced. The board part number is WPW10192966 and when replaced we get three green lights (prewash-wash-rinse) in the center to light up and the red door locked light also. But that's it the machine will do nothing else but these lights lit up. We've gone as far as unplugging everything from this board and only supply line voltage to it with nothing else plugged into it or out of it and the same lights will come on only and nothing else responds. The unit in the shop has had every part replaced with the same result wire harness, door lock, etc... There are no programming instructions supplied with the part and I checked the Whirlpool Service Matters website and found nothing regarding this part or the machine's tech sheet. I'm open for any suggestions at this point, the original problem with the machine in the shop was it would not drain, no power being supplied to drain motor if that helps any. I would appreciate any help regarding this problem and was hoping maybe someone else ran into this. Thanks and be safe people.

I'll try to post up some pictures.
« Last Edit: April 24, 2020, 11:10:36 AM by Blackbeener »