Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Frigidaire FPUH19D7LF1 compressor fan not running  (Read 3541 times)

Offline Jellowe

  • VIP Member
  • Member Since: May 2017
  • Posts: 2
Frigidaire FPUH19D7LF1 compressor fan not running
« on: May 31, 2017, 07:03:48 AM »

My freezer stopped cooling and I found that the fan for the compressor was not running. The compressor is working, I can hear it hum and feel it vibrate, and the copper lines are cold. I replaced the fan motor and it still does not work. There is a thermistor (or thermostat?) connected to the fan that is not listed on the parts diagram. I snipped the wires to the thermister and byassed it to get the fan to run, but I cannot find this part. The power goes into the thermistor which attaches to the copper line in the back of the freezer, then from there to the fan. This is not the defrost thermostat which is located inside the freezer lower panel, this is on the back side of the freezer near the compressor and fan. The parts diagram simply does not show it. I have googled the numbers and can't find it. I will attach a photo but here are the number off of it. I hope someone will be able to help with a compatible part I can use. Thank you.

297337200
FR-9N24/-3
030813

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 5258
  • Country: us
Re: Frigidaire FPUH19D7LF1 compressor fan not running
« Reply #1 on: May 31, 2017, 09:51:46 AM »
Yeah i cannot find it either,but can find the Tech Sheet. Seems to be used for a cold area where they don't want the condenser fan to come on until it reaches a certain temperature. If the freezer is in the house i would just leave it jump out.

Offline Jellowe

  • VIP Member
  • Member Since: May 2017
  • Posts: 2
Re: Frigidaire FPUH19D7LF1 compressor fan not running
« Reply #2 on: May 31, 2017, 06:43:38 PM »
Thanks. I bypassed it and just let the fan run. However now I think I still have an issue.  The coils (inside the bottom panel, interior of freezer) start to get a little frost at the top left corner where the line comes in, but after a minute it stops cooling. No longer cool to the touch, no frost. If I unplug the freezer for a few minutes and plug it back in, same thing. It starts to cool the coils but then stops. I know there's a thermistor in that bottom panel that reports the temp to the board. Could that be flaky? Or more likely something on the compressor? Refrigerant?  Thank you.

Offline sarjushah

  • VIP Member
  • Member Since: Dec 2014
  • Posts: 70
Re: Frigidaire FPUH19D7LF1 compressor fan not running
« Reply #3 on: June 01, 2017, 06:32:25 AM »
if the compressor is running, fans are running and it is not cooling then it seems like sealed system issue. i would check the amp draw on compressor and should be close to 1 amp.

Offline dif

  • VIP Member
  • Member Since: Aug 2022
  • Posts: 2
Re: Frigidaire FPUH19D7LF1 compressor fan not running
« Reply #4 on: August 29, 2022, 09:14:55 AM »
Does anyone else have any input on this sensor shown in this thread? Frigidaire acts like it doesn't exist. Part number 297337200. No one seems to know what is does or where to get one.