Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Samsung RF4287HARS Fridge freezing food, everything else works great.  (Read 400 times)

Offline jeepguy25

  • VIP Member
  • Member Since: May 2017
  • Posts: 2

Hi everyone! So...Just need to sort out ONE more issue with my fridge.

Fridge is a RF4287HARS. Everything appears to work great. It even makes ice and dispenses water! haha.

The problem is, the fridge section is freezing our food/drinks. Settings are 0 for the freezer and 46 for the fridge. Using a thermometer, the freezer is confirmed to be at 0 almost all the time. The flex drawer is set to 37, and confirmed that it stays at 37 all the time. The fridge is set to 46, but is usually 30 degrees, and even dips into the mid 20s. WAY too cold. The front display panel always shows 0 and 46...it never fluctuates. Which is weird to me.

I checked the thermister resistances at the back panel, and they all seemed to register fine at their given temps, though I didnt check to see if they changed with a different temp. Here is the strange thing. If I unplug the unit, then plug it back in, the temps on the front panel will match the actual values for a bit. The display shows 30 degrees, and will move its way up to 46 and then stay. But before I gets up there, the compressor is back on and cooling the fridge back down BELOW 46.

My intuition is telling me that its a control issue. This is one of the twin cooling units, with an evap in the freezer, and an evap in the fridge section. I dont believe there is a blend door between fridge and freezer like on a single evap system. There is only a door between the flex drawer and the fridge. Since the drawer is fine, I think the blend is ok. Correct me if Im wrong here. 

I want to try a new main control board... The one that is in there is a replacement that was put in before I got it. There was an odd wiring issues on the compressor turn on harness...which is what my original problem was. The part number for the board that is installed is DA41-00683A. The board number listed in the service manual that I downloaded is DA41-00684A. So Im sort of hoping thats enough to fix the issue.

I know that was a lot... Just fishing around a bit to see if anyone has any more good info.

Thanks,

Justin

Offline jeepguy25

  • VIP Member
  • Member Since: May 2017
  • Posts: 2
Just wanted to update.

I ordered a new thermistor...but after some reading, Im learning that any of the thermistors in the unit can cause an issue in the fridge compartment.  Even if its a flex zone or other sensor. 

I tried to do the "options" trick last night.  Where you hold the two buttons and you can go in and put in a correction factor for the temperature.  I selected mode 1 which according to the manual is for the fresh food side.  I changed it so it should have been 8 degrees warmer.  It made no change.  So either A) the manual is wrong, and mode 1 isnt for the fresh food side, or B) the main board is ignoring the thermistors and my settings and doing its own thing.  Im leaning towards popping a new board in just to see how it behaves.  Worst case I can return it. 

Justin