Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: WHIRLPOOL GAS OVEN BAKE & BROIL WONT LIGHT MODEL WFG510S0AS1  (Read 762 times)

Offline goldenteeking

  • VIP Member
  • Member Since: May 2016
  • Posts: 3
WHIRLPOOL GAS OVEN BAKE & BROIL WONT LIGHT MODEL WFG510S0AS1
« on: September 14, 2016, 01:21:20 PM »

BOTH IGNITORS SPARK AND THE GAS FLOWS FOR 1/4 OF A SEC BUT DOESNT LIGHT. BAKE WENT OUT FIRST THEN THE BROIL A COUPLE WEEKS LATER.

Offline baldwinappliance

  • Technician
  • Member Since: Feb 2014
  • Posts: 229
  • Country: us
Re: WHIRLPOOL GAS OVEN BAKE & BROIL WONT LIGHT MODEL WFG510S0AS1
« Reply #1 on: September 14, 2016, 11:09:12 PM »
you may need to replace the harness from the DSI to the bake and broil ignitors. some models the wires were just covered in fiberglass and it is possible for the spark to go through the insulation and ground out on the cabinet so you don't get a spark at the probe.  Take the back panels off and look at the wires.  If they are both not coated in thick black rubber then that MIGHT be your problem.  Here is the part number: WPW10701462.  Also attaching the tech manual. If I come across one with the old wire harness then I replace it as it will be a problem sooner or later.  You have to take a few screws off the left side panel in the back and ease it out a bit to have enough access to remove the old and run the new one.

Hope that helps.  :cheers:

Offline goldenteeking

  • VIP Member
  • Member Since: May 2016
  • Posts: 3
Re: WHIRLPOOL GAS OVEN BAKE & BROIL WONT LIGHT MODEL WFG510S0AS1
« Reply #2 on: September 15, 2016, 01:25:40 PM »
Thanks very much for your help. I really appreciate the insight.