Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Your Privacy Rights

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: new whirlpool waasher dead display  (Read 2195 times)

Offline Joeyt56

  • Technician
  • Member Since: Jul 2014
  • Posts: 115
new whirlpool waasher dead display
« on: March 17, 2015, 03:22:17 PM »

Whirlpool wfw70hebw1 front load washer. When I plug the machine in i hear a beep then the drain pump kicks on but there's no display. Nothing on the user interface responds. If I unplug the user interface and then plug the washer in it no longer drains. The second I reconnect the interface the pump kicks on  and still no display. I'm guessing since I know the interface is getting power that something in it shorted and thats what I need to replace not the main control. Does that sound about right to anyone else?

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 5256
  • Country: us
Re: new whirlpool waasher dead display
« Reply #1 on: March 17, 2015, 04:55:31 PM »
I can give you a Tech Sheet.Maybe someone can offer you some advise. https://drive.google.com/file/d/0B-i5KqMA2RZweDNQRTlpRWlBejQ/view?usp=sharing  Also a Technical Pointer Sheet. https://drive.google.com/file/d/0B-i5KqMA2RZwa2JrczNlTzFfNVE/view?usp=sharing
« Last Edit: March 17, 2015, 05:07:52 PM by dab147315 »

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 5256
  • Country: us
Re: new whirlpool waasher dead display
« Reply #2 on: March 17, 2015, 05:42:40 PM »
Manual seems pretty good about how to check user interface.

Offline Joeyt56

  • Technician
  • Member Since: Jul 2014
  • Posts: 115
Re: new whirlpool waasher dead display
« Reply #3 on: March 17, 2015, 05:57:35 PM »
Yeah now that I think of it I don't remember the service LED ever coming on. Thanks for the info.

Offline dab147315

  • Technician
  • Member Since: Oct 2010
  • Posts: 5256
  • Country: us
Re: new whirlpool waasher dead display
« Reply #4 on: March 17, 2015, 06:01:21 PM »
Let us know what happens.

Offline Joeyt56

  • Technician
  • Member Since: Jul 2014
  • Posts: 115
Re: new whirlpool waasher dead display
« Reply #5 on: March 17, 2015, 06:03:31 PM »
Will do, I'll order the acu tomorrow. At least the acu is available unlike the console.

Offline curjones

  • Technician
  • Member Since: Nov 2013
  • Posts: 370
  • Country: us
  • Service Tech, Owner
    • Buy me a beer through paypal
Re: new whirlpool waasher dead display
« Reply #6 on: October 19, 2015, 10:08:45 PM »
any update on this post?.. customer is describing this problem.. E1 F8..  going to be looking at the pressure transducer as first on my list. connections... corrosion.
was the ACU bad or the sensor?
About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack(diet coke in my case) . The small green square=personal message.

Offline Joeyt56

  • Technician
  • Member Since: Jul 2014
  • Posts: 115
Re: new whirlpool waasher dead display
« Reply #7 on: October 19, 2015, 10:26:52 PM »
Unfortunately no the customer decided not to repair it, guess he picked one up from a friend.

Offline curjones

  • Technician
  • Member Since: Nov 2013
  • Posts: 370
  • Country: us
  • Service Tech, Owner
    • Buy me a beer through paypal
Re: new whirlpool waasher dead display
« Reply #8 on: October 19, 2015, 11:16:17 PM »
Thanks,  Had same thing happen on Ge last week.. stumped me.. think it was pressure switch... but never got to prove it.. acted like bad control board.. but new board did not fix it..
About the icons: The beer is tip link, if a tech saves ya some money buy em a 6 pack(diet coke in my case) . The small green square=personal message.