Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Whirlpool Cabrio Washer F51 Error  (Read 37756 times)

Offline TechnicianBrian

  • Technician
  • Member Since: Dec 2007
  • Posts: 390
  • Country: us
Whirlpool Cabrio Washer F51 Error
« on: September 08, 2008, 07:24:25 AM »

Model # WTW6200SW0, this top load washer would intermittently display an error message during a wash cycle requiring the load to be started again after clearing the display. The problem was infrequent at the beginning, but continued to get worse with time. After trying different sized loads thinking there may be some correlation, the customer finally called for service to get it fixed.

The F51 error is a RPS (rotary position sensor) board failure where the control board looses contact with the RPS during the machines operation. The RPS uses hall effect sensors to determine the speed and direction of the drive motor, allowing the control board to constantly monitor the motors operation. Because this error is a communication error and not a mechanical error with the motor itself (that would be and F52 error) we can limit our trouble shooting to the three items that make up the RPS circuit, the control board, the wiring harness, and the RPS itself.

Looking at the wiring diagram for the RPS circuit, we will find a wiring harness consisting of brown wires connecting to the top of the control board. From here, we can test for our output voltage on pin 6. As long as we have our 15vdc on this pin, that indicates the control board is working. Our next stop is under the machine to locate the RPS board.

Tipping the machine back will reveal the motor directly underneath the tub. The RPS board is mounted on the right side (follow the brown wires) and under the motors rotor disk. An Allen wrench is used to remove the rotor and then the four bolts holding the motor stator to the tub can be removed. Once the motor is out, we can get to the RPS and the wiring harness and do a continuity check on each wire between each end of the harness. If our readings indicate a good harness, we are down to the RPS itself and it would need to be replaced. Of course there is one other thing to do, and that is make sure the connection from the harness to the board is good.

Many of these boards were manufactured with a clear lacquer being applied to the boards to protect the wire traces, and unfortunately, many of the contacts themselves became covered. This results in a poor connection to the harness connector and provides for an poor intermittent signal to the control board. To repair this unit, I removed the RPS board and using my jewelers file, cleaned the contacts for proper electrical connection. Once everything was reassembled, it ran two complete diagnostic cycles without a hiccup. And now the customer can get some laundry done without restarting the machine.

(RPS) Rotor Position Sensor Part # W10183157

Offline Semperfi4000

  • VIP Member
  • Member Since: Dec 2008
  • Posts: 1
Re: Whirlpool Cabrio Washer F51 Error
« Reply #1 on: December 21, 2008, 06:58:58 AM »
TechnicianBrian,  thank you. your article help me find my problem.  I'm not a professional, when fixing appliances.

Although, it wasn't the Sensor. It was the bolt that holds the rotor, it was loose.  Over the few years, I had to take the tub out, because baby clothes and other small articles of clothing fall behind the tub.  I guess, the bolt holding the rotor would loosen each time I took out the tub. 
Again, thank you so much..


  • VIP Member
  • Member Since: Jun 2013
  • Posts: 6
Re: Whirlpool Cabrio Washer F51 Error
« Reply #2 on: August 06, 2013, 02:57:40 PM »
Great info....unfortunate for me this machine is coing F52. So from your info posted do I conclude it's the motor? Are there any test to check the motor and or the RPSensor? I read on another forum Whirlpool says to replace all three :  MOTOR...HARNESS...and RPS !! Is that any way  to correctly repair any machine...meaning CHANGE ALL PARTS.? There has got to be a way to pinpoint the fauty item or items. Thanks

Offline Just a Guy

  • VIP Member
  • Member Since: Jan 2014
  • Posts: 1
Re: Whirlpool Cabrio Washer F51 Error
« Reply #3 on: January 07, 2014, 01:56:21 PM »
Regarding your continuity test -does every connection to the RPS have to have continuity with every terminal of the P connector?  Or does it have to have only 1?

Offline hocky88

  • VIP Member
  • Member Since: Feb 2014
  • Posts: 4
Re: Whirlpool Cabrio Washer F51 Error
« Reply #4 on: February 26, 2014, 12:18:12 AM »
I have this same error F51 on my wtw6600sw1.  WHat is confusing is that it passes the manual test as I can clearly see 3 lights with no skips etc.  But in trying to run the spin test it never even gets close to the low rpm and simply kicks to F51.  My control board is a W10189966 rev c and my rps sensor is 8565188 rev a.  I am desperately needing some ideas!  I even tested tonight with the inner basket removed to be sure nothing on the top inside was dragging.  No luck.  I have a working unit and am able to swapsome parts - I tried swappping the user interface board - no change.  I have no clue..If the manual test of the rps would fail at least I would have some things to check.  I am lost with this!

Offline Lee28

  • VIP Member
  • Member Since: Sep 2014
  • Posts: 1
Re: Whirlpool Cabrio Washer F51 Error
« Reply #5 on: September 09, 2014, 06:57:41 PM »
Hello Brian.

I just want to say I followed your thread for my F51 error, cleaned the connections to the sensor with a file and put the washer back together. It worked. I was able to run a full cycle and when it got to the spin it didn't error out. I'm psyched! Granted I'm technical but for telecommunications not appliances. THANKS AGAIN.

Offline coverland

  • VIP Member
  • Member Since: Oct 2015
  • Posts: 2
Re: Whirlpool Cabrio Washer F51 Error
« Reply #6 on: October 22, 2015, 07:39:04 PM »
I am also getting F51. I have had my washer for about 6 years. In that time I have replaced the Stator and the Shaft and bearings once. I had to replace the Shaft and bearings again as the seal failed recently and started leaking pretty bad.

Once I replaced the hardware, I am still getting F51. I have tested the RPS board (looking at your photo, mine is a bit different, with a rectangular pug with 2 rows of 3 wires... comparing the plug to the wiring diagram and wire colors, I was able to figure out which connector is which on the board. So.. I tested the points and between 6-5=1.19K(0.31K out of tolerance), 6-4=1.50K, 6-3=1.52k and 1-7=9.72k

ALSO, I was able to do the manual spin and only got 2 of the 3 display lights to blink. Wash would just stay on constantly, Rinse and Spin would blink.

I am assuming that I need to replace the RPS board. Does this seem correct?  :thanks:

Offline coverland

  • VIP Member
  • Member Since: Oct 2015
  • Posts: 2
Re: Whirlpool Cabrio Washer F51 Error
« Reply #7 on: October 25, 2015, 06:42:08 PM »
Well, as an update... I was able to order just the RPS, installed it and ran the spin test, all is good.. The washer is working again.

Offline AJ

  • Technician
  • Member Since: Jun 2007
  • Posts: 10865
  • Country: us
    • - Appliance Repair
Re: Whirlpool Cabrio Washer F51 Error
« Reply #8 on: October 29, 2015, 04:16:24 PM »
Thanks for the update!


Whirlpool Cabrio washer error code f32

Started by lseighman

Replies: 4
Views: 5790
Last post May 21, 2014, 10:00:49 AM
by johnboy3
Whirlpool Duet Washer - F-30 error code and clunking noise in detergent area.

Started by AJ

Replies: 3
Views: 20400
Last post November 15, 2009, 09:34:58 AM
by AJ
Whirlpool Duet Washer Error Codes

Started by AJ

Replies: 0
Views: 32574
Last post September 13, 2008, 10:38:25 PM
by AJ
Whirlpool Duet Washer F5 Error Code

Started by TechnicianBrian

Replies: 2
Views: 19179
Last post October 05, 2008, 08:39:47 PM
by TechnicianBrian

Started by IPSONDN1

Replies: 3
Views: 13073
Last post December 12, 2008, 12:48:37 PM

Started by guillaumef33

Replies: 1
Views: 4450
Last post December 31, 2008, 05:05:44 AM
by Repair-man