Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: GE Hydra Wave Washer will not agitate or Spin  (Read 958 times)

Offline slater

  • VIP Member
  • Member Since: Aug 2015
  • Posts: 2
GE Hydra Wave Washer will not agitate or Spin
« on: August 18, 2015, 12:07:07 PM »

Thank you for your generous advice.

I have a GE Washer WPRE6150k2WT; Hydrowave green LED on Motor inverter board; no flap.  The unit fills and drains but will not agitate or spin.

The LED on the motor inverter board flashes 1 sec on and 1 second off (no motor movement) so no error and I assume the fuse is OK.  The LID open LED display works as well as stopping the filling when the LID is open so I assume the LID switch works ( also from voltage readings below).  I obtained a reading of 68 ohms (not 98) across the mode shifter.

Motor inverter board:

C2 connector:
- 120 V pin 5 (RB) to ground.
- 120 V pin 6 (SX) with lid down ( 0v with Lid up)

C4 Connector (same readings in mode selector “drain/spin” and service mode SP)
All pins 54 V.  (Pins RX, YX, NX,BX, VX)

C? Second from right (connector not on the schematic but two wires Lt Blue and Black to motor coils) wires 120v all the time.


Thank you so much for any insight

Offline slater

  • VIP Member
  • Member Since: Aug 2015
  • Posts: 2
Re: GE Hydra Wave Washer will not agitate or Spin
« Reply #1 on: August 18, 2015, 02:47:33 PM »
Original poster

I assume it is either the motor assembly or timer/control board. How can I test the motor and timer? Thank you