Get Answers to your Appliance Repair Questions

Disclosure: This website contains affiliate links, Meaning I get a commission if you decide to make a purchase through my links, at no cost to you.

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: maytag bravos top load washer model mvwb850wro  (Read 1339 times)

Offline gregaguilar

  • Technician
  • Member Since: Jan 2012
  • Posts: 276
maytag bravos top load washer model mvwb850wro
« on: March 15, 2015, 12:07:52 PM »

i picked up this washer and am working on it so i can resell,. The problem on it is no lites no power no nothing when you pug it in. Now as per teck sheet it states If no indicator lites light up, No beep sound is heard .1. Perform steps in Acessing and removing the Electronic assemblies, page 6 and visualy check that the P7 connector is inserted all the way into the machine/motor control. 2 visually check the the user interface assembly is properly inserted in the console assembly. 3 If both visual checks pass, REPLACE THE USER INTERFACE ASSEMBLY? hERE IS WHAT I JUST DONT UNDERSTAND ABOUT THE TECH ADVISE---iF THIS DOESNT WORK THEN AND THEN GO AHEAD AND REPLACE THE MACHINE/MOTOR CONTROL????? There has got to be a better way of isolating either one of this so as to not have to spend all that money by trial and error does any body have some input to this situation.? I checked and am getting power to the motor control assembly but how do i check for power going to the user interface board ? I am going to be doing some more research on this but mean while some of u tecks might shed some lite on this. Thanks ahead of time.