Get Answers to your Appliance Repair Questions

Washer Parts  ·   Dryer Parts  ·   Refrigerator Parts  ·   Dishwasher Parts  ·   Range/Cooktop/Oven Parts  ·   All Appliance Parts 

Author Topic: Kenmore 90 Plus series : Slow cold water fill  (Read 2413 times)

Offline jfw0928

  • VIP Member
  • Member Since: Nov 2012
  • Posts: 38
Kenmore 90 Plus series : Slow cold water fill
« on: March 30, 2014, 12:21:17 PM »

Model 110.28932790

Cold water fill is at about a quarter of the rate of hot water fill regardless of using/not using Automatic Temperature Control setting (picture attached). With supply lines disconnected from washer, hot and cold water flow is comparable. The filter screens in the inlet valve are free of sediment. I'm thinking that the inlet valve may be faulty. But, was wondering if anyone is aware of something else that may be causing this problem before I purchase the part.

Thank you.
« Last Edit: March 30, 2014, 12:22:56 PM by jfw0928 »

Offline tgoods

  • Technician
    Moderator
  • Member Since: Jul 2010
  • Posts: 1902
  • Country: us
    • Buy me a beer through paypal
Re: Kenmore 90 Plus series : Slow cold water fill
« Reply #1 on: March 30, 2014, 04:09:58 PM »
I like to backflush these with a shopvac.  Turn off the cold water and disconnect the hose from the valve. Turn the washer on warm water fill and use the shopvac to pull the hot water backward through the valve.  If that doesn't work, replace the valve.

Offline jfw0928

  • VIP Member
  • Member Since: Nov 2012
  • Posts: 38
Re: Kenmore 90 Plus series : Slow cold water fill
« Reply #2 on: March 30, 2014, 05:56:40 PM »
TGoods, Very clever. Thank you for the tip. Just to be certain I am following - You are attaching the shop vac to the cold water inlet valve while the machine is attempting to fill with warm water. Is there any particular device that you are using to get a snug connection on the inlet valve?
« Last Edit: March 30, 2014, 05:58:32 PM by jfw0928 »

Offline lesguns

  • Technician
  • Member Since: Aug 2011
  • Posts: 156
  • Country: us
Re: Kenmore 90 Plus series : Slow cold water fill
« Reply #3 on: March 30, 2014, 07:36:12 PM »
you may have a screen in the hose on the faucet.

Offline jfw0928

  • VIP Member
  • Member Since: Nov 2012
  • Posts: 38
Re: Kenmore 90 Plus series : Slow cold water fill
« Reply #4 on: April 04, 2014, 12:08:01 AM »
Thank you Lesguns. With the supply hoses detached from the machine, the water flow is basically the same.

I wasn't able to figure out how to perform the reverse flush procedure. So, I replaced the inlet valve - still the same issue.