Forum Index => Dryer Repair => Topic started by: beyondx4 on September 22, 2010, 11:07:13 AM

Title: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on September 22, 2010, 11:07:13 AM
I've recently bought a used Admiral washer and gas dryer set. I believe the dryer initially heated up well, however, I later found out that the Automatic settings would not work correctly (it gets stuck), but the minute timed settings work. The result was that it got stuck on the Auto setting and the dryer ran on for 2-3 hours, excessively drying my clothes, and possibly overheating some components of the dryer. On my 2nd use, I noticed that the dryer would no longer heat up. After doing some research, I figure the coils may be bad, so I bought a new set with a 2-prong and a 3-prong coil. After swapping them out, I found out that there was still no heat. I opened it back up and checked the igniter; it seems to glow up just fine, however, there is no flame or burning gas. The igniter would glow for 10sec, then turn off, repeating this cycle a few times per minute. I'd appreciate it if some knowledgeable member might be able to point me to the right direction.

Model ADG7005AWW (

( (
( (
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: JWWebster on September 22, 2010, 11:27:43 AM
Sounds to me like your control thermostat (mounted on the blower housing) I faulty.
This Amana gas and electric dryer manual will help you check components:
Amana dryer service manual (

Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on September 22, 2010, 04:31:41 PM
Thank you for your input. The service manual was very helpful as it shows the exact model of my dryer. This is my first time trying to service a dryer. Anyway, may I ask, what role does the limit (or control) thermostat play in a gas dryer, or more specifically, how is it stopping my dryer from heating up? Did my previous overheating of the dryer damaged the thermostat? Finally, I assume the thermostat has nothing to do with my dryer getting stuck under AUTO setting, is that correct? Thanks again!
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: JWWebster on September 22, 2010, 08:28:39 PM
The control is mounted on the blower housing. It judges the temp coming from the drum area. When it gets to 160 max for cotton it shuts down till around 105 then it kicks back in again. Some have 4 wires. 2 big wires carry the load and 2 smaller wires serve to warm up a tiny heater in the control. This tiny heater makes the control shut down faster for delicate and permanent press. Those tend to go haywire from time to time. This thermostat does play apart in the non sensing type dryer with auto features screwing up it's routine.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on September 22, 2010, 10:31:44 PM
Thanks for the information JW. I will start searching for the control thermostat as I've found the part number (it's a 2 terminal thermostat). Since I've replaced the Valve Coils and that didn't help, I hope this will be the culprit. From what you've described, it appears my thermostat is either shutting down the heating before it could flame up, or maybe dead-open and not even sensing anything. I will open the dryer up again this weekend to measure the resistance between the thermostat's 2 terminals, as instructed in the service manual. Will post updates to help others w/ similar problems.

Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on September 23, 2010, 01:26:15 AM
Another question I'd like to ask is: Does the FLAME SENSOR have anything to do with any of the symptoms I've described? Here's a breakdown of my troubleshooting steps:

1. Gas present (can smell a bit of it)
2. Ignitor glows strong when start (then dies in 15secs & repeat)
3. No flame or burning present
4. Good strong pressure at vent outside (but cool air)
5. Replaced both holding/booster coils on gas valve today (same results).
6. Next target: replace the limit/control thermostat.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: JWWebster on September 23, 2010, 12:07:57 PM
Could be one of them safety's is getting age on them and they are shutting down. Run it and and quickly check each component. After it dies. You know the ignitor is good and the flame sensor is good and the coils are new. So it is gonna either be a limit or a control stat. If could be the 250 degree limit that mounts on the burner chamber. I would definitly check that one after it dies. Remove the wires from each component. This does 2 things. Keeps from getting a false reading and sometimes the stat just falls apart.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: theoldstoveguy on September 23, 2010, 09:30:00 PM
Natural or LP gas? I have seen burner heads fall apart on LP. This would in fact give the same symptom. Spider web in burner is another. You would in fact smell gas on the outlet of your duct when it runs on both problems.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on September 25, 2010, 03:59:34 AM
I'm using natural gas. I believe the dryer worked okay before that one time it got stuck running for 3hrs (I've just recently bought it used, though in very good condition). I'm currently back at my parents house for the weekend and once I return, will open the dryer back up to check the continuity of the thermostat. If it doesn't test right, then I'll order a new one (only about $12 on ebay). Honestly, it is a fairly simple setup and I'm not sure what else could be the problem. I guess the final step would be just to replace the whole gas valve assembly if I hit a dead-end by next week.  :embarassed:
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: JWWebster on September 25, 2010, 10:10:27 AM
I do not think you are going to have to do that. Remember do the tests directly after the appliance fails.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on September 27, 2010, 09:17:09 PM
I finally had a chance to open my dryer up again today and noticed something discouraging, the 2-prong connector & the secondary coil is all charred up.  Part of the wiring harness has also melted.  The 3-prong booster coil and its harness appears to be ok. This was even worse than the other day. I hope my roommate didn't attempt to use the dryer while I was gone. Ok, so I took my coils and tested their resistance; its similar to reference (@ 1300, 560, & 1200 ohms), so I think even my old coils are ok. Now when I tested the limit thermostat, it gave me 0.8-0.9ohms (ref. says it should be > 1ohm). I also noticed a similar looking 2-terminal device next to the limit thermostat that is mounted slightly higher on the burner housing, which also gave similar resistance (this device wasn't listed in the service manual).

So first things first, I'll need to trace down and rebuild the wiring harness tomorrow. Now according to the numbers above does it still seem like a thermostat issue? or Could it be that my wiring harness was faulty to begin with (possibly melted when I overheated the dryer when it got stuck running for 3hrs)? Thank you.

Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on October 04, 2010, 11:00:20 PM
After attempting to rewire my harness at the gas valve area, I noticed my ignitor's wires (in heatproof insulation) is charred up beyond use. I'll have to purchase a new ignitor. I will also purchase a new thermostat to be sure. I have another question: what is the difference between a cycling thermostat and a limit thermostat? Thanks.

Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: JWWebster on October 05, 2010, 10:28:07 AM
The cycling thermostat needs to be replaced and the limits. The cycling thermostat is mounted on the blower housing. Its maximum temp is 160f. That is for cotton. NUMBER 31  ( is the cycle thermostat. If someone was to put a limit there instead of the cycling thermostat then the temp would shut down at 250f and start melting everything. Is that what happened?

The limit is number 10 and the thermal cutout is number 33. If the dryer over heats this dude is supposed to melt and kill the gas assembly. Has number 33 been bypassed? I can't imagine them gas valve wires getting hot to the point of melting without someone monkeying around with the safetys.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on October 05, 2010, 04:51:17 PM
Now that I see this parts diagram, it's much clearer. I've been thinking the control thermostat (31) was actually the limit thermostat (10); I couldn't even identify the thermal cutout (33) initially. No, I believe the positions of the limit and control thermostat has not been tampered with. The thermal cutout wires remain untouched and not bypassed (unless the melting of the wires have somehow caused it to be bypassed).

About the melting of the gas valve wires, I have a feeling it happened AFTER I replaced the valve coils. It looked pretty bad then, but not all melted down. I swapped each valve coil wire one-by-one. One thing I did noticed before replacing is that the secondary coil was initially mounted upside-down (the terminals were on the bottom & the guide hole wasn't in its slot). So I flipped it over and screwed everything back together. The dryer was test-run a couple min afterwards, but it never heated up because the gas flame wouldn't ignite, so I shut it off, turn off gas, but did not unplug the power. A few days later when I opened up the dryer to measure the thermostat, the wires have COMPLETELY melted. Another thing I noticed is the gas valve output was not completely in-line with the inlet hole on the burner housing (which may have redirected the gas in the wrong direction).
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: jumptrout51 on October 06, 2010, 07:51:41 AM
You need to find and repair the short circuit in the dryer.
Remove all wires and test each one to ground.
Check all component terminals to ground.
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on October 06, 2010, 10:17:09 AM
It's been awhile since I've worked with electricity. So in order to find the short circuit, will my multimeter need to be set to check for continuity and then I'll need to see if any of the terminals or wires has continuity with the chassis ground?

Anyway, before I could start measuring, the first thing I'll need to do is replace all the melted wire on the harness around the gas valve area. Luckily everything is still intact so that I could rewire and solder each terminal individually. Of course, the only 2 wires I couldn't do anything about is the two heat-insulated wires coming off the ignitor.

Thanks alot for everybody's help!
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on October 26, 2010, 09:34:48 AM
Just an update on my attempt at repairing my gas dryer. After rebuilting the wiring harness around the valve coils, installing the new igniter, and reassembling the dryer that I've torn apart; I fired it up: there were flames in the burner and heat in the exhaust pipe!

I've been backtracking my fixes and replicating the issue: I believe I've turned the dial pointer on the AUTO setting too far (between "Less Dry" & "Off"). This probably knocked the dial outside of its operating range, causing it to stick (which sometimes happen on my little oven). The dryer overheated after running for 3hrs and possibly damaged part of the harness, shorting it somewhere. As a result, it never heated up afterwards; even after replacing the valve coils. Worse yet, the next morning, I found the the harness around the valve had melted badly and the wires from the igniter burnt up beyond use (I'd left the dryer plugged in overnight).

Now that it's back up and running, I'm able to successfully get the AUTO settings to operate normally by keeping the pointer within the "Very Dry to Less Dry" range; however, upon testing, I've found that the manual TIMER setting is much more consistent and haven't failed. So I'll likely stick to this rather than using any of the AUTO settings, just to be safe. Anyway, I appreciate everybody's contribution...not only saving the dryer, but more importantly, I've attained a new skill!

-DV   ;D
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: AJ on October 26, 2010, 10:38:12 AM
Glad to hear you got it working again.
Thanks for the update.  O0
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: elite on October 28, 2010, 08:53:25 PM
please check your venting sounds like you had a lynt fire very rare that wires around coils catch on fire unless there is a venting issue allowing the flame to curl backwards from the burner tube
Title: Re: Admiral Dryer (ADG7005AWW) won't heat
Post by: beyondx4 on October 29, 2010, 01:59:11 AM
Thanks. The day after the fix, I went ahead and shortened/cleared the venting hole to make it more efficient. The couple of elbows might've contributed to the initial problem causing the dial to stick.

The crazy thing is that the melting of the wires near the valve happened AFTER I opened the dryer up to replace the valve coils (which I thought was broken not allowing the dryer to produce any heat; however, I later found out the igniter lights up, but it cannot light up a flame). I was disappointed and shut off the gas and quit. A few days later, I opened it up again only to find out that the wirings have completely melted, which suggested something shorted and probably lighted up the igniter while I was away. A member suggested I must first eliminate the short, which I did while carefully rebuilding the harness. After I plugged it back in, to my surprise, the dryer worked like new!