ApplianceJunk.com

Forum Index => Washer Repair => Topic started by: tibor on June 15, 2013, 09:51:28 PM

Title: Model #GLWS1979AS3 Frigidaire Washer not spinning
Post by: tibor on June 15, 2013, 09:51:28 PM
Hello,
Model #GLWS1979AS3 Frigidaire Washer does not spin. It pumps fine and agitates as well but would not spin. Makes nose, like the pump is running dry for a while.
Any good idea is appreciated.
Thanks in advance.
Title: Re: Model #GLWS1979AS3 Frigidaire Washer not spinning
Post by: tgoods on June 15, 2013, 10:10:25 PM
Try spinning the inner tub, counter-clockwise.  It should spin freely.  If it doesn't, you may have a sock stuck between the tubs or a bad lower bearing in the transmission.  I've never seen a tub bearing seize up, but I suppose it's possible.  The lower bearing is not available, only the whole transmission, 134737100.
Title: Re: Model #GLWS1979AS3 Frigidaire Washer not spinning
Post by: tibor on June 15, 2013, 10:42:31 PM
Thank you for the quick response. It turns freely though.
Title: Re: Model #GLWS1979AS3 Frigidaire Washer not spinning
Post by: tgoods on June 15, 2013, 11:25:48 PM
Check your belt and idler pulley.
Title: Re: Model #GLWS1979AS3 Frigidaire Washer not spinning
Post by: tibor on June 15, 2013, 11:33:55 PM
I did and they look fine. I smell some burning but can't locate the source. First I thought it was the belt but the belt is intact. When on the spin cycle the motor doesn't seam to turn at all. The burning smell may be coming from the pump since it looks like running dry after the water is emptied. Could something be with the lid lock switch? I red something to that fact somewhere.