ApplianceJunk.com

Forum Index => Refrigerator & Freezer Repair => Topic started by: haroldsappliance on February 07, 2013, 12:44:02 PM

Title: Whirlpool refrig md# mfi2568aes
Post by: haroldsappliance on February 07, 2013, 12:44:02 PM
Whirlpool refrig md# mfi2568aes. No ice production. Icemaker thermistor 1050 ohms at room temperature. Ice room damper opens and closes in diagnostic mode, but stays closed in normal run mode. I'm thinking control board is the most likely suspect,  I'm wondering if any of you guys have run across this problem before. The thermister for the ice room is p# 67006438 you can see that it comes with a new wiring harness and I am curious to know what the deal is with this. I'm thinking this thermister is probably the same as p# 12002355  would love some feedback. Thanks.
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: haroldsappliance on February 07, 2013, 12:45:59 PM
http://www.repairclinic.com/PartDetail/Ice-Maker/67006438/1187310
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: haroldsappliance on February 13, 2013, 01:21:51 PM
Has no one out there had any experience with this "ice box" icemaker in the wpl ref?
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: Bailey on February 13, 2013, 04:32:27 PM
This looks like Maytags ICE2o model. I think there is a service manual in AJ's collection. I've only worked on one of these, so can't offer any advice.
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: haroldsappliance on February 13, 2013, 07:36:03 PM
Thank you but I already have a manual. I was looking for someone with some hands on experience with this particular box.
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: AJ on February 14, 2013, 06:49:40 AM
Only worked on a couple too. None for no ice problems, sorry.
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: AJ on February 21, 2013, 01:04:34 PM
Did you end up finding the solution?
Title: Re: Whirlpool refrig md# mfi2568aes
Post by: haroldsappliance on February 21, 2013, 07:55:21 PM
This is actually a ref that that my brothers company was looking at. I think what he ended up doing was to lower the actual temp in the "ice box". Unit appears to be working correctly now. I am almost positive that the thermistor is  the standard p# 12002355 (http://click.linksynergy.com/fs-bin/click?id=omv7WULuxaw&subid=0&offerid=225193.1&type=10&tmpid=2111&RD_PARM0=http%253A%252F%252Fwww.appliancepartspros.com%252Fwhirlpool-thermistor-kit-12002355-ap4009169.html&RD_PARM1=http&RD_PARM2=%253A%252F%252Fwww.appliancepartspros&RD_PARM3=.com%252Fwhirlpool-thermistor-kit-12002355-ap4009169.html). It was first apparent that the damper was not opening to allow proper cooling to ice box area. We shall see.