ApplianceJunk.com

Forum Index => Dishwasher Repair => Topic started by: tagarman on January 13, 2013, 08:26:42 PM

Title: Kitchenaid dishwasher won't run thru complete cycle w/6-4 fault code
Post by: tagarman on January 13, 2013, 08:26:42 PM
Hello everybody,  I got a call on a 1-1/2 year old Kitchenaid dishwasher model no: KUDS30FXSS0 & serial no: F04703336 that won't always run thru the complete cycle.  It will shut off before the dry cycle.  I ran the diag. cycle and got a 6-4 error code.  Followed the tech sheet for that code, checked overflow float-OK, water valve-OK, electronic control board F9 fuse-OK.  The only thing I found was that there was no drain hose loop under the kitchen sink.  So I installed a drain loop as high as possible.  My customer called and said the dishwasher will run all the way thru about 2 out of 5 times.  If anybody has ever had this problem and could tell me what to do I would love to hear from you.  Thank You very much!
Title: Re: Kitchenaid dishwasher won't run thru complete cycle w/6-4 fault code
Post by: AJ on January 16, 2013, 06:39:32 AM
6-4 on the tech sheet.

Quote
Can Start a Cycle, but Only Runs
for a Short Time
- Cycle Does Not Complete (Clean LED or Completed May Blink)

Quote
Control canceled cycle due to error detected with wash motor,
float switch, low water, or suds.

Did you check to see if polarity was correct on the power coming into the dishwasher and that it had a good ground?

What type of water supply do they have?
Do they have good water pressure all the time?
Title: Re: Kitchenaid dishwasher won't run thru complete cycle w/6-4 fault code
Post by: AJ on February 10, 2013, 08:56:50 AM
Got any updates for us?  :popcorn:
Title: Re: Kitchenaid dishwasher won't run thru complete cycle w/6-4 fault code
Post by: tagarman on February 17, 2013, 04:33:17 PM
They have city water with good pressure.  I have not been able to get back with the customer to check polarity since  she says it works sometimes and when it does shut down it just won't dry so she dries the dishes by hand.  She has not called me back in a while.  When she does I check polarity, you never know as I was told her husband installed the dishwasher.  Maybe it is wired backwards.  I'll keeps you guys informed on the outcome.  Thanks,  Tom
 
Title: Re: Kitchenaid dishwasher won't run thru complete cycle w/6-4 fault code
Post by: Bailey on February 17, 2013, 04:42:23 PM
I had a whirlpool do this to me. First time it worked fine.I sat there until was partly through the dry cycle then got tired of waiting and left.The customer called a couple of days later and it had quit again. I managed to catch it this time. It temporarily had lost power at the junction box.The wiring went behind the lazy susan.Someone had spliced the romex with wire nuts and a loose connection had developed. I don't know if this is your problem, but just an idea.
Title: Re: Kitchenaid dishwasher won't run thru complete cycle w/6-4 fault code
Post by: tagarman on February 24, 2013, 07:15:36 PM
Bailey, Thanks for the input.  I'm still waiting for her to call me back so I can check it out.  When I do I'll take off the junction box to check polarity & for loose connections.  I'll let you know how it turns out.  Thanks again, Tom